After 5 years serving the vintage Apple enthusiast community, ThinkClassic has been marked for closure and is now in caretaker mode. Please see this thread for further information. Please direct any questions, comments and enquiries about the website, management and ownership to this thread.

You are not logged in.

#1 2018-01-10 21:15:55

Registered: 2018-01-10
Posts: 1

Can’t get Mac OS X Public Beta installed on Power Mac G4

Hello, I can’t get the Mac OS X Public Beta installed on my Power Mac G4 (AGP). I can get through the install process but when it boots it brings up this:


- This Public Beta disc installs fine on my iBook G3 clamshell, so I don’t think it’s that.

- I see “Firewire” several times in the error message, but I don’t have any Firewire devices connected, so I don’t think it’s a hardware compatability problem.

- I thought it was maybe a RAM issue because of the “Memory access exception” line. I took out the extra RAM the computer had, but nothing changed.

- The only things I have plugged in to the computer, aside from the VGA monitor, are an offical Apple USB mouse and keyboard. I tried booting with them disconnected, but that didn't fix it.

- I tried booting without the disc inserted, since I read that that could solve a problem like this, but that didn’t work.

- The computer can boot into Developer Preview 2 and 3, but it has the same problem with Developer Preview 4. I haven’t tried 10.0, but 10.1 works fine. I got the same problem when I installed Developer Preview 4 on an iMac G3. It would boot into this screen too, even though it is supposed to be able to run it.

Really really hoping somebody can please help me with this. smile


Board footer

About ThinkClassic

ThinkClassic specialises in the use, maintenance, repair, restoration and modification of vintage computers and peripherals.